use strict;
my $str = '3/26/24
11/26/24
1/2/03
4/05/2006';
my $regex = qr/\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b/p;
my $subst = '${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";