// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b").unwrap();
let string = "3/26/24
11/26/24
1/2/03
4/05/2006";
let substitution = "${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}