import Foundation
let pattern = #"\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
3/26/24
11/26/24
1/2/03
4/05/2006
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)