const regex = /\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(\\d)|(\\d{2}))\\\/(?:(\\d)|(\\d{2}))\\\/(?:(\\d{2})|(\\d{4}))\\b', 'g')
const str = `3/26/24
11/26/24
1/2/03
4/05/2006`;
const subst = `${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);