re = /\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b/
str = '3/26/24
11/26/24
1/2/03
4/05/2006'
subst = '${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result