package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b`)
var str = `3/26/24
11/26/24
1/2/03
4/05/2006`
var substitution = "${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}"
fmt.Println(re.ReplaceAllString(str, substitution))
}