import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(\\d)|(\\d{2}))\\/(?:(\\d)|(\\d{2}))\\/(?:(\\d{2})|(\\d{4}))\\b";
final String string = "3/26/24\n"
+ "11/26/24\n"
+ "1/2/03\n"
+ "4/05/2006";
final String subst = "${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}