import re
regex = re.compile(r"\b(?:(\d)|(\d{2}))\/(?:(\d)|(\d{2}))\/(?:(\d{2})|(\d{4}))\b")
test_str = ("3/26/24\n"
"11/26/24\n"
"1/2/03\n"
"4/05/2006")
subst = "${5:+20$5:$6}-${1:+0$1:$2}-${3:+0$3:$4}"
result = regex.sub(subst, test_str)
if result:
print(result)