# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)[:=](\w+),?/KEY: \1, VALUE: \2\n/g;t' <<< "key1=value1,key2=value2,key3=value3"