#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w+)[:=](\w+),?"
Local $sString = "key1=value1,key2=value2,key3=value3"
Local $sSubst = "KEY: \1, VALUE: \2\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)