use strict;
my $str = 'key1=value1,key2=value2,key3=value3';
my $regex = qr/(\w+)[:=](\w+),?/p;
my $subst = 'KEY: \\1, VALUE: \\2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";