package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)[:=](\w+),?`)
var str = `key1=value1,key2=value2,key3=value3`
var substitution = "KEY: \1, VALUE: \2\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}