import re
regex = re.compile(r"(\w+)[:=](\w+),?")
test_str = "key1=value1,key2=value2,key3=value3"
subst = "KEY: \\1, VALUE: \\2\\n"
result = regex.sub(subst, test_str)
if result:
print(result)