using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)[:=](\w+),?";
string substitution = @"KEY: \1, VALUE: \2\n";
string input = @"key1=value1,key2=value2,key3=value3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}