re = /(\w+)[:=](\w+),?/
str = 'key1=value1,key2=value2,key3=value3'
subst = 'KEY: \\1, VALUE: \\2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result