$re = '/(\w+)[:=](\w+),?/';
$str = 'key1=value1,key2=value2,key3=value3';
$subst = "KEY: \1, VALUE: \2\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;