import Foundation
let pattern = #"(\w+)[:=](\w+),?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"key1=value1,key2=value2,key3=value3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"KEY: \1, VALUE: \2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)