const regex = /(\w+)[:=](\w+),?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)[:=](\\w+),?', 'g')
const str = `key1=value1,key2=value2,key3=value3`;
const subst = `KEY: \1, VALUE: \2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);