# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(UNION ALL\D*?historical;)/\\/\*\1\*\\//gm;t' <<< "@b =
SELECT *
FROM @e;
UNION ALL
SELECT *
FROM @c_historical;
@r =
SELECT *
FROM @f;
UNION ALL
SELECT *
FROM @y_historical;"