import Foundation
let pattern = #"(UNION ALL\D*?historical;)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@b =
SELECT *
FROM @e;
UNION ALL
SELECT *
FROM @c_historical;
@r =
SELECT *
FROM @f;
UNION ALL
SELECT *
FROM @y_historical;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\/\*\1\*\/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)