const regex = /(UNION ALL\D*?historical;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(UNION ALL\\D*?historical;)', 'gm')
const str = `@b =
SELECT *
FROM @e;
UNION ALL
SELECT *
FROM @c_historical;
@r =
SELECT *
FROM @f;
UNION ALL
SELECT *
FROM @y_historical;`;
const subst = `\/\*\1\*\/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);