import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(UNION ALL\\D*?historical;)";
final String string = "@b =\n"
+ " SELECT *\n"
+ " FROM @e;\n"
+ " UNION ALL\n"
+ " SELECT *\n"
+ " FROM @c_historical;\n\n\n"
+ "@r =\n"
+ " SELECT *\n"
+ " FROM @f;\n"
+ " UNION ALL\n"
+ " SELECT *\n"
+ " FROM @y_historical;";
final String subst = "\\/\\*\\1\\*\\/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}