// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(UNION ALL\D*?historical;)").unwrap();
let string = "@b =
SELECT *
FROM @e;
UNION ALL
SELECT *
FROM @c_historical;
@r =
SELECT *
FROM @f;
UNION ALL
SELECT *
FROM @y_historical;";
let substitution = "\\/\\*\\1\\*\\/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}