# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d*)\d{2}\b/$1XX BLOCK/gm;t' <<< "1091 foo address
\" --> \"10XX BLOCK foo address\"
1016 foo 1010 address
\" --> \"10XX BLOCK foo 1010 address\"
foo 1081 address
\" --> \"foo 1081 address\"
10 bar address
\" --> \"XX BLOCK bar address\"
8 baz address
\" --> \"8 baz address\""