using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d*)\d{2}\b";
string substitution = @"$1XX BLOCK";
string input = @"1091 foo address
"" --> ""10XX BLOCK foo address""
1016 foo 1010 address
"" --> ""10XX BLOCK foo 1010 address""
foo 1081 address
"" --> ""foo 1081 address""
10 bar address
"" --> ""XX BLOCK bar address""
8 baz address
"" --> ""8 baz address""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}