use strict;
my $str = '1091 foo address
" --> "10XX BLOCK foo address"
1016 foo 1010 address
" --> "10XX BLOCK foo 1010 address"
foo 1081 address
" --> "foo 1081 address"
10 bar address
" --> "XX BLOCK bar address"
8 baz address
" --> "8 baz address"';
my $regex = qr/^(\d*)\d{2}\b/mp;
my $subst = '$1XX BLOCK';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";