package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d*)\d{2}\b`)
var str = `1091 foo address
" --> "10XX BLOCK foo address"
1016 foo 1010 address
" --> "10XX BLOCK foo 1010 address"
foo 1081 address
" --> "foo 1081 address"
10 bar address
" --> "XX BLOCK bar address"
8 baz address
" --> "8 baz address"`
var substitution = "$1XX BLOCK"
fmt.Println(re.ReplaceAllString(str, substitution))
}