import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d*)\\d{2}\\b";
final String string = "1091 foo address\n"
+ "\" --> \"10XX BLOCK foo address\"\n"
+ "1016 foo 1010 address\n"
+ "\" --> \"10XX BLOCK foo 1010 address\"\n"
+ "foo 1081 address\n"
+ "\" --> \"foo 1081 address\"\n"
+ "10 bar address\n"
+ "\" --> \"XX BLOCK bar address\"\n"
+ "8 baz address\n"
+ "\" --> \"8 baz address\"";
final String subst = "$1XX BLOCK";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}