const regex = /^(\d*)\d{2}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*)\\d{2}\\b', 'gm')
const str = `1091 foo address
" --> "10XX BLOCK foo address"
1016 foo 1010 address
" --> "10XX BLOCK foo 1010 address"
foo 1081 address
" --> "foo 1081 address"
10 bar address
" --> "XX BLOCK bar address"
8 baz address
" --> "8 baz address"`;
const subst = `$1XX BLOCK`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);