# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)\B(\"\b(.*?)\b\"|\"\")\B/\\q{$1}/gm;t' <<< "This is my \"te
st\" case
with lines for \"tes\"t\"ing\" with regex
But as he said \"It could be an arbitray ammount of words\"
and meet empty \"\" quotes as well
and not correct \"starting and \"ending quote\""