import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\B(\\\"\\b(.*?)\\b\\\"|\\\"\\\")\\B";
final String string = "This is my \"te\n\n"
+ "st\" case\n"
+ "with lines for \"tes\"t\"ing\" with regex\n"
+ "But as he said \"It could be an arbitray ammount of words\"\n\n"
+ "and meet empty \"\" quotes as well\n"
+ "and not correct \"starting and \"ending quote\"";
final String subst = "\\\\q{$1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}