const regex = /(?s)\B(\"\b(.*?)\b\"|\"\")\B/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\B(\\"\\b(.*?)\\b\\"|\\"\\")\\B', 'gm')
const str = `This is my "te
st" case
with lines for "tes"t"ing" with regex
But as he said "It could be an arbitray ammount of words"
and meet empty "" quotes as well
and not correct "starting and "ending quote"`;
const subst = `\\q{$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);