using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\B(\""\b(.*?)\b\""|\""\"")\B";
string substitution = @"\\q{$1}";
string input = @"This is my ""te
st"" case
with lines for ""tes""t""ing"" with regex
But as he said ""It could be an arbitray ammount of words""
and meet empty "" quotes as well
and not correct ""starting and ""ending quote""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}