// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?s)\B(\"\b(.*?)\b\"|\"\")\B"#).unwrap();
let string = "This is my \"te
st\" case
with lines for \"tes\"t\"ing\" with regex
But as he said \"It could be an arbitray ammount of words\"
and meet empty \"\" quotes as well
and not correct \"starting and \"ending quote\"";
let substitution = "\\\\q{$1}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}