#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)\B(\"\b(.*?)\b\"|\"\")\B"
Local $sString = "This is my "te" & @CRLF & _
"" & @CRLF & _
"st" case" & @CRLF & _
"with lines for "tes"t"ing" with regex" & @CRLF & _
"But as he said "It could be an arbitray ammount of words"" & @CRLF & _
"" & @CRLF & _
"and meet empty "" quotes as well" & @CRLF & _
"and not correct "starting and "ending quote""
Local $sSubst = "\\q{$1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)