use strict;
my $str = 'This is my "te
st" case
with lines for "tes"t"ing" with regex
But as he said "It could be an arbitray ammount of words"
and meet empty "" quotes as well
and not correct "starting and "ending quote"';
my $regex = qr/(?s)\B(\"\b(.*?)\b\"|\"\")\B/mp;
my $subst = '\\\\q{$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";