import Foundation
let pattern = #"(?s)\B(\"\b(.*?)\b\"|\"\")\B"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is my "te
st" case
with lines for "tes"t"ing" with regex
But as he said "It could be an arbitray ammount of words"
and meet empty "" quotes as well
and not correct "starting and "ending quote"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\q{$1}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)