re = /(?s)\B(\"\b(.*?)\b\"|\"\")\B/m
str = 'This is my "te
st" case
with lines for "tes"t"ing" with regex
But as he said "It could be an arbitray ammount of words"
and meet empty "" quotes as well
and not correct "starting and "ending quote"'
subst = '\\\\q{$1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result