# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)\B(\"\b(.*?)\b\"|\"\")\B"
test_str = ("This is my \"te\n\n"
"st\" case\n"
"with lines for \"tes\"t\"ing\" with regex\n"
"But as he said \"It could be an arbitray ammount of words\"\n\n"
"and meet empty \"\" quotes as well\n"
"and not correct \"starting and \"ending quote\"")
subst = "\\\\q{$1}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.