package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)\B(\"\b(.*?)\b\"|\"\")\B`)
var str = `This is my "te
st" case
with lines for "tes"t"ing" with regex
But as he said "It could be an arbitray ammount of words"
and meet empty "" quotes as well
and not correct "starting and "ending quote"`
var substitution = "\\q{$1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}