# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<h[1-2].*?>(.*?)<\\/h[1-2]>/<h2>$1<\/h2>/gm;t' <<< "<h1>Hola</h1>asdasdasd
<h1>Test</h1>"