package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<h[1-2].*?>(.*?)<\/h[1-2]>`)
var str = `<h1>Hola</h1>asdasdasd
<h1>Test</h1>`
var substitution = "<h2>$1</h2>"
fmt.Println(re.ReplaceAllString(str, substitution))
}