import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h[1-2].*?>(.*?)<\\/h[1-2]>";
final String string = "<h1>Hola</h1>asdasdasd\n\n"
+ "<h1>Test</h1>";
final String subst = "<h2>$1</h2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}