// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<h[1-2].*?>(.*?)<\/h[1-2]>").unwrap();
let string = "<h1>Hola</h1>asdasdasd
<h1>Test</h1>";
let substitution = "<h2>$1</h2>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}