#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<h[1-2].*?>(.*?)<\/h[1-2]>"
Local $sString = "<h1>Hola</h1>asdasdasd" & @CRLF & _
"" & @CRLF & _
"<h1>Test</h1>"
Local $sSubst = "<h2>$1</h2>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)