using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h[1-2].*?>(.*?)<\/h[1-2]>";
string substitution = @"<h2>$1</h2>";
string input = @"<h1>Hola</h1>asdasdasd
<h1>Test</h1>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}