re = /<h[1-2].*?>(.*?)<\/h[1-2]>/m
str = '<h1>Hola</h1>asdasdasd
<h1>Test</h1>'
subst = '<h2>$1</h2>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result