import Foundation
let pattern = #"<h[1-2].*?>(.*?)<\/h[1-2]>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<h1>Hola</h1>asdasdasd
<h1>Test</h1>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<h2>$1</h2>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)