use strict;
my $str = '<h1>Hola</h1>asdasdasd
<h1>Test</h1>';
my $regex = qr/<h[1-2].*?>(.*?)<\/h[1-2]>/mp;
my $subst = '<h2>$1</h2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";