const regex = /<h[1-2].*?>(.*?)<\/h[1-2]>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h[1-2].*?>(.*?)<\\\/h[1-2]>', 'gm')
const str = `<h1>Hola</h1>asdasdasd
<h1>Test</h1>`;
const subst = `<h2>$1</h2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);